Ticket #1447 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

python-module fails to load plugins that import from dbus

Reported by: jagow Owned by: dgollub
Priority: normal Milestone:
Component: OpenSync Version: 0.39
Severity: normal Keywords:
Cc:

Description

This bug appears in current Opensync SVN:

A python plugin that has an import statement set as follows:

import dbus
from dbus.mainloop.glib import DBusGMainLoop
from dbus.mainloop.glib import threads_init
import gobject
import thread
import threading
import time
import sys
import logging
import opensync
import array

is not correctly loaded by the python-plugin.

Executing

osynctool --sync synce

gives:

Traceback (most recent call last):
  File "/usr/lib64/libopensync1/python-plugins/synce-opensync-plugin-3x.py", line 61, in <module>
    import dbus
  File "/usr/lib/python2.7/site-packages/dbus/__init__.py", line 79, in <module>
    import dbus.types as types
  File "/usr/lib/python2.7/site-packages/dbus/types.py", line 6, in <module>
    from _dbus_bindings import ObjectPath, ByteArray, Signature, Byte,\
ImportError: /usr/lib64/python2.7/site-packages/_dbus_bindings.so: undefined symbol: PyExc_UserWarning
Synchronizing group "synce" 

Error Summary:
ROOT CAUSE: "Couldn't load module synce-opensync-plugin-3x"

No other issues with dbus and python elsewhere on the system (stock OpenSUSE 11.4)

Change History

comment:1 Changed 2 years ago by markellis

  • Status changed from new to closed
  • Resolution set to fixed

Due to plugins being dlopen'ed with BIND_LOCAL to preserve the namespace. Python plugin is now EXTERNAL in Chris Frey's git repo to avoid this.

Note: See TracTickets for help on using tickets.