Ticket #387 (reopened defect)

Opened 7 years ago

Last modified 4 years ago

Opensync reports an "no node at all" with nokia 3230, 6670 and 7610

Reported by: stareagle Owned by: dgollub
Priority: high Milestone:
Component: Plugin: syncml Version: 0.22
Severity: critical Keywords: nokia 3230 6670 7610
Cc:

Description

If iI try to sync my Nokia 3230 via SyncML (http), Opensync reports

"no node at all"

There also no tracefiles (I have set the variables as described in doc).

Attachments

opensync3230.tar.gz (12.7 KB) - added by stareagle 7 years ago.
syncmlhttp.tar.gz (36.6 KB) - added by stareagle 7 years ago.
syncmlobex.tar.gz (44.3 KB) - added by stareagle 7 years ago.
traces.tar.gz (28.6 KB) - added by hn75 7 years ago.
syncml-client.tgz (20.2 KB) - added by jaimono 7 years ago.
Trace files for syncml-obex-client with the nokia 6670 phone
syncml-server.tgz (16.9 KB) - added by jaimono 7 years ago.
Trace files for syncml-http-server with the nokia 6670 phone
syncml-client_7-feb-2007.tgz (25.7 KB) - added by jaimono 7 years ago.
Traces and logs for syncml-obex-client

Change History

comment:1 Changed 7 years ago by dgollub

  • Owner changed from abauer to dgollub
  • Status changed from new to assigned
  • Component changed from OpenSync to Plugin: syncml

Can you try to reproduce this with the syncml-http-server command line tool and provide trace file of this. (export SYNCML_TRACE=/tmp/syncml_trace/; # for libsyncml tracing) http://libsyncml.opensync.org/wiki/http-guide

Regarding the trace files problem. Did you build OpenSync? by yourself? Package from which distribution/repository? Maybe OpenSync? in the build debugging is disabled...

comment:2 Changed 7 years ago by stareagle

Sorry for late reply. I forgot this ticket completly...

Yesterday I found this ticket while looking for my problem at Google..

I'm using the Gentoo EBuilds.

You were right with the debuging features. The useflag "debug" was not set for the EBuild. Now here are the trace files (syncml-obex-client). But the syncml-http-server has the same error.

Changed 7 years ago by stareagle

comment:3 Changed 7 years ago by dgollub

The OSYNC_TRACE files don't help. Please provide SYNCML_TRACE files and additional SYNCML_LOG.

export SYNCML_TRACE=/tmp/traces/ export SYNCML_LOG=/tmp/traces/ mkdir /tmp/traces msynctool --sync foobar

Changed 7 years ago by stareagle

Changed 7 years ago by stareagle

comment:4 Changed 7 years ago by stareagle

Sorry, so this should be all files you need... I would be glad if you could tell me what is wrong...

comment:5 Changed 7 years ago by hn75

Hi

I experience the same problems using pakages from debian etch -> opensync-plugin-syncml (0.19-1)

$obex_test -u
Using USB transport, querying available interfaces
Interface 0: Nokia Nokia 3230 SYNCML-SYNC
Interface 1: Nokia Nokia 3230 PC Suite Services
Use 'obex_test -u interface_number' to run interactive OBEX test client
<config>
        <interface>0</interface>
        <identifier>PC Suite</identifier>
        <version>1</version>
        <wbxml>1</wbxml>
        <username></username>
        <password></password>
        <type>5</type>
        <usestringtable>1</usestringtable>
        <onlyreplace>0</onlyreplace>
        <recvLimit>10000</recvLimit>
        <contact_db>Contacts</contact_db>
        <calendar_db>Calendar</calendar_db>
        <note_db>Notes</note_db>
</config>
$msynctool --sync Nokia3230-file

Synchronizing group "Nokia3230-file"
The previous synchronization was unclean. Slow-syncing
Member 1 of type file-sync just connected
received event dsession
received contact dsession
received note dsession
Member 2 of type syncml-obex-client just connected
All clients connected or error
Member 1 of type file-sync just sent all changes
Member 2 of type syncml-obex-client had an error while getting changes: No node at all
Member 1 of type file-sync just disconnected

I used export export SYNCML_LOG=/tmp/traces/ export SYNCML_TRACE=/tmp/traces/

I will attach the archive of /tmp/traces

If you need more info I would be happy to help you.

Thanks

Hendrik

Changed 7 years ago by hn75

comment:6 Changed 7 years ago by jaimono

  • Keywords nokia 3230 6670 added
  • Summary changed from Opensync reports an "no node at all" with nokia 3230 to Opensync reports an "no node at all" with nokia 3230 and nokia 6670

I'm having the same problem with my nokia 6670 (http://forum.nokia.com/devices/6670: Symbian OS v7.0s, S60 2nd Edition, Feature Pack 1).

Since I've noticed that the problem is in syncml I'm using syncml-obex-client and syncml-http-server to make tests.

First I tried using the usb cable:

jaime@mundomono:~/log$ export SYNCML_TRACE=/home/jaime/log/syncml-client
jaime@mundomono:~/log$ export SYNCML_LOG=/home/jaime/log/syncml-client
jaime@mundomono:~/log$ syncml-obex-client --dumpinfo -u 0 --identifier "PC Suite" --wbxml --sync text/x-vcard Contacts
connection with device succeeded
Received an Alert for the DS Server at Contacts: Type: 201, Last , Next 20070124T232850Z
Just received a new session with ID 26
Received the DevInf
Session 26 reported final. flushing
There was an error in the session 26: No node at allSend the output below to the libsyncml developers

========================================
Man: NOKIA
Mod: 7610
FirmwareVersion: (null)
SoftwareVersion: 6.0522.0
HardwareVersion: (null)

ReceiveLimit: 0
MaxObjSize: 0
Connection used: Obex
Identifier: PC Suite

Databases:
DB Locations: Contacts
DB Type: text/x-vcard
DB Slow: 0

Bluetooth: Unknown
Wbxml: Yes
SyncML Version: 1.1
SupportsNumberofChanges: Yes
SupportsLargeObjects: Yes

I also have gnubox (bluetooth network access) installed and configured in the phone with dund in my Linux machine so I configured the phone syncml cliend and tried with the syncml server:

jaime@mundomono:~/log$ export SYNCML_TRACE=/home/jaime/log/syncml-server 
jaime@mundomono:~/log$ export SYNCML_LOG=/home/jaime/log/syncml-server
jaime@mundomono:~/log$ syncml-http-server --dumpinfo --port 5079 --sync text/x-vcard contacts
Received an Alert for the DS Server at contacts: Type: 201, Last , Next 20070124T234251Z
Slowsyncing
Just received a new session with ID 7
Received the DevInf
Session 7 reported final. flushing
There was an error in the session 7: No node at allSend the output below to the libsyncml developers

========================================
Man: NOKIA
Mod: 7610
FirmwareVersion: (null)
SoftwareVersion: 6.0522.0
HardwareVersion: (null)

ReceiveLimit: 0
MaxObjSize: 0
Connection used: Obex

Databases:
DB Locations: contacts
DB Type: text/x-vcard
DB Slow: 0

SyncML Version: 1.1
SupportsNumberofChanges: Yes
SupportsLargeObjects: Yes

And the phone client fails with: "Server not responding!".

I'm using the debian packages from http://www.in.fh-merseburg.de/~jahn/. The current libsyncml version is:

jaime@mundomono:~/log$ apt-cache show libsyncml0
Package: libsyncml0
Version: 0.4.2+svn20070118-etch1
Architecture: i386
Depends: libbluetooth2 (>= 3.0), libc6 (>= 2.3.6-6), libexpat1 (>= 1.95.8), libgcrypt11 (>= 1.2.2), libglib2.0-0 (>= 2.12.0), libgnutls13 (>= 1.4.0-0), libgpg-error0 (>= 1.4), libopenobex1, libpopt0 (>= 1.10), libsoup2.2-8 (>= 2.2.98), libtasn1-3 (>= 0.3.4), libwbxml2-old, libxml2 (>= 2.6.27), zlib1g (>= 1:1.2.1), libwbxml2-old
Installed-Size: 312
Maintainer: Armin Bauer <armin.bauer@desscon.com>
Source: libsyncml
Priority: optional
Section: libs
Filename: pool/main/libs/libsyncml/libsyncml0_0.4.2+svn20070118-etch1_i386.deb
Size: 100858
MD5sum: 3473bd6793dffee688e5cc02c4a83fb9
Description: SyncML protocol library
 Libsyncml implement the SyncML protocol. It support SyncML version 1.0,
 1.1 and 1.2. The available transport are Obex and Http. This library can be
 used as a client or as a server.

Package: libsyncml0
Priority: optional
Section: libs
Installed-Size: 304
Maintainer: Michael Banck <mbanck@debian.org>
Architecture: i386
Source: libsyncml
Version: 0.4.1-1
Depends: libbluetooth2 (>= 3.0), libc6 (>= 2.3.6-6), libexpat1 (>= 1.95.8), libgcrypt11 (>= 1.2.2), libglib2.0-0 (>= 2.12.0), libgnutls13 (>= 1.4.0-0), libgpg-error0 (>= 1.4), libopenobex1, libpopt0 (>= 1.10), libsoup2.2-8 (>= 2.2.96), libtasn1-3 (>= 0.3.4), libwbxml2-0 (>= 0.9.2-2), libxml2 (>= 2.6.27), zlib1g (>= 1:1.2.1)
Filename: pool/main/libs/libsyncml/libsyncml0_0.4.1-1_i386.deb
Size: 97684
MD5sum: 3b68e78f0eb6b57925d0a73a7627373f
SHA1: b763cd51d2307015f0f3df1a5b3185e1cbe05d92
SHA256: f450bc9f03fae6304ff640ad9ce46ffcd026e6ea661a43df9014c1d0a4ab1591
Description: SyncML protocol library
 Libsyncml implement the SyncML protocol. It supports SyncML version 1.0,
 1.1 and 1.2. The available transport are Obex and Http. This library can be
 used as a client or as a server.
Tag: role::shared-lib

I will attach the log files and also be glad to send any other information you need.

Thanks

Jaime.

Changed 7 years ago by jaimono

Trace files for syncml-obex-client with the nokia 6670 phone

Changed 7 years ago by jaimono

Trace files for syncml-http-server with the nokia 6670 phone

comment:7 Changed 7 years ago by jaimono

  • Priority changed from normal to high

comment:8 Changed 7 years ago by dgollub

  • Status changed from assigned to closed
  • Resolution set to wontfix

I can reproduce this... but only with wbxml2 0.9.0. So there is something wrong in wbxml2 0.9.0. wbxml2 0.9.2 works fine and the WBXML got correct converted to XML. Please update to wbxml2 0.9.2 You can find packages of wbxml2 0.9.2 in the OpenSync?-devel repository of the openSUSE Buildserivce: http://software.opensuse.org/download/OpenSync-devel/

Thanks for reporting!

comment:9 Changed 7 years ago by jaimono

  • Status changed from closed to reopened
  • Resolution wontfix deleted
  • Severity changed from normal to critical

I'm not using openSUSE, I'm using Debian etch and getting the packages with the following apt's sources.list line:

deb http://www.in.fh-merseburg.de/~jahn/ etch main

Here is the package information:

wbxml

jaime@mundomono:~$ apt-cache show libwbxml2-0
Package: libwbxml2-0
Priority: optional
Section: libs
Installed-Size: 208
Maintainer: Riku Voipio <riku.voipio@iki.fi>
Architecture: i386
Source: wbxml2
Version: 0.9.2-3
Replaces: libwbxml2
Depends: libc6 (>= 2.3.6-6), libexpat1 (>= 1.95.8), libpopt0 (>= 1.10), zlib1g (>= 1:1.2.1)
Conflicts: libwbxml2
Filename: pool/main/w/wbxml2/libwbxml2-0_0.9.2-3_i386.deb
Size: 65378
MD5sum: ee9532d12e35e02f46c6d36987bc6c2d
SHA1: 7a4a7e77aae7f8beee0cc42205542c1e14de2686
SHA256: b15a078886e5cbead2db0f76bff09f645dab57bb93cdea4f06acdf82593b17d0
Description: WBXML parsing and encoding library
 The WBXML Library (aka libwbxml) contains a library and its associated
 tools to Parse, Encode and Handle WBXML documents.  The WBXML format
 is a binary representation of XML, defined by the Wap Forum, and used
 to reduce bandwidth in mobile communications.
 .
 This package contains the dynamic library needed by applications
 using libwbxml2.
Tag: role::shared-lib

libsyncml

jaime@mundomono:~$ apt-cache show libsyncml0
Package: libsyncml0
Version: 0.4.2+svn20070131-etch1
Architecture: i386
Depends: libbluetooth2 (>= 3.0), libc6 (>= 2.3.6-6), libexpat1 (>= 1.95.8), libgcrypt11 (>= 1.2.2), libglib2.0-0 (>= 2.12.0), libgnutls13 (>= 1.4.0-0), libgpg-error0 (>= 1.4), libopenobex1, libpopt0 (>= 1.10), libsoup2.2-8 (>= 2.2.98), libtasn1-3 (>= 0.3.4), libwbxml2-0 (>= 0.9.2-2), libxml2 (>= 2.6.27), zlib1g (>= 1:1.2.1)
Conflicts: libwbxml2-old
Installed-Size: 312
Maintainer: Armin Bauer <armin.bauer@desscon.com>
Source: libsyncml
Priority: optional
Section: libs
Filename: pool/main/libs/libsyncml/libsyncml0_0.4.2+svn20070131-etch1_i386.deb
Size: 101562
MD5sum: cd71b24d9d0f78858682d9cf88588d96
Description: SyncML protocol library
 Libsyncml implement the SyncML protocol. It support SyncML version 1.0,
 1.1 and 1.2. The available transport are Obex and Http. This library can be
 used as a client or as a server.

opensync

jaime@mundomono:~$ apt-cache show libopensync0
Package: libopensync0
Version: 0.20+svn20070206-etch1
Architecture: i386
Depends: libc6 (>= 2.3.6-6), libglib2.0-0 (>= 2.12.0), libsqlite3-0 (>= 3.3.8), libxml2 (>= 2.6.27)
Recommends: msynctool (>= 0.19)
Installed-Size: 724
Maintainer: Matthias Jahn <jahn.matthias@freenet.de>
Source: libopensync
Priority: optional
Section: libs
Filename: pool/main/libo/libopensync/libopensync0_0.20+svn20070206-etch1_i386.deb
Size: 222588
MD5sum: 2c68cdbcee01d663ce75854a7cb880a4
Description: Synchronisation framework for email/pdas/and more
 A synchronisation framework for synchronising data in various format. You
 can use libopensync from programs. See multisync for an existing X11 gui
 program that uses opensync.
 This package contains libs and osplugin binary.

And I'm still getting the same problem:

jaime@mundomono:~$ export SYNCML_TRACE=/home/jaime/log/syncml-client/
jaime@mundomono:~$ export SYNCML_LOG=/home/jaime/log/syncml-client/
jaime@mundomono:~$ syncml-obex-client -u 0 --wbxml --identifier "PC Suite" --sync text/x-vcard Contacts --sync text/x-vcalendar Calendar
connection with device succeeded
Just received a new session with ID 29
Received an Alert for the DS Server at Calendar: Type: 201, Last , Next 20070207T165922Z
Received an Alert for the DS Server at Contacts: Type: 201, Last , Next 20070207T165922Z
Received the DevInf
Session 29 reported final. flushing
There was an error in the session 29: No node at alljaime@mundomono:~$

Once again, the logs and traces are attached

Changed 7 years ago by jaimono

Traces and logs for syncml-obex-client

comment:10 Changed 7 years ago by pmarat

could you please try:

syncml-obex-client -u 0 --wbxml --identifier "PC Suite" \
--slow-sync text/x-vcard Contacts --version "1.2"

comment:11 Changed 7 years ago by jaimono

Of course, but it still fails:

jaime@mundomono:~$ syncml-obex-client -u 0 --wbxml --identifier "PC Suite" \
> --slow-sync text/x-vcard Contacts --version "1.2"
connection with device succeeded
Received an transport error: Request not successfull: 64

comment:12 Changed 7 years ago by dgollub

A more closer look shows that wbxml 0.9.2 really breaks on this wbxml dump... I try to contact the wbxml2 maintainer. Btw. which firmware version are used? (In case of that the wbxml is malformed...)

comment:13 Changed 7 years ago by akriegisch

I stumbled across the same problem with my Nokia 6670 but I could solve that: (My system is debian/unstable with the very same package versions; I do sync via syncml-http-server) setting usestringtable to 0 did the job for me. Another thing was that I had to set recvLimit to 10000 (as it is already done in the config above). My config looks like this and works just fine: <?xml version="1.0"?> <config>

<username></username> <password></password> <url>/</url> <port>8080</port> <usestringtable>0</usestringtable> <onlyreplace>0</onlyreplace> <onlyLocaltime>0</onlyLocaltime> <recvLimit>10000</recvLimit> <maxObjSize>0</maxObjSize> <contact_db>contacts</contact_db>

</config>

I hope this helps... best regards,

Adi Kriegisch (mailto:adi_AT_vrvis_dot_at)

comment:14 Changed 7 years ago by stareagle

  • Status changed from reopened to closed
  • Resolution set to fixed

This works for me also (with Opensync 2.1 an plugins, thank to the fast gentoo package maintainer!).

Also many many thanks to Adi for the working config! And, of course to the developers of OpenSync?!

comment:15 Changed 7 years ago by jaimono

  • Status changed from closed to reopened
  • Version changed from 0.20 to 0.21
  • Resolution fixed deleted

Well, I have tried it in Debian etch and does not works! And I don't want to change to sid so I'm stuck with "no node at all" :'( The line in my sources.list is:

deb http://www.in.fh-merseburg.de/~jahn/opensync-0.21/ etch main

And these are the versions:

libopensync-plugin-syncml: 0.21-etch3 Maintainer: Matthias Jahn
libopensync0: 0.21.1-etch4 Maintainer: Matthias Jahn
msynctool: 0.20+svn20070207-etch1 Maintainer: Matthias Jahn
opensyncutils: 0.21.1-etch4 Maintainer: Matthias Jahn
libsyncml0: 0.4.3-etch1  Maintainer: Armin Bauer
libsyncml-utils: 0.4.3-etch1  Maintainer: Armin Bauer

comment:16 Changed 7 years ago by hn75

Hi jaimono

I got a connection at least via bluetooth using debian etch and

deb http://www.in.fh-merseburg.de/~jahn/opensync-0.21/ etch main

My config looks like

msynctool --showgroup nokia-kdepim
Groupname: nokia-kdepim
Member 1: kdepim-sync
        No Configuration found: This member has no configuration options
Member 2: syncml-obex-client
        Configuration : <config>
<username></username>
<password></password>
<type>2</type>
<bluetooth_address>00:13:70:1A:8F:83</bluetooth_address>
<bluetooth_channel>11</bluetooth_channel>
<interface>0</interface>
<version>0</version>
<identifier>hendrik-0</identifier>
<wbxml>1</wbxml>
<recvLimit>0</recvLimit>
<maxObjSize>0</maxObjSize>
<usestringtable>0</usestringtable>
<onlyreplace>0</onlyreplace>
<contact_db>addressbook</contact_db>
<calendar_db>calendar</calendar_db>
<note_db>notes</note_db>
</config>

comment:17 Changed 6 years ago by dgollub

Sorry for the late response - i can reproduce this now again. Looks like a wbxml parsing issue (again). wbxml2-0.9.2_SVN48-29

I'll try now latest SVN version (53) of wbxml2.

comment:18 Changed 6 years ago by dgollub

wbxml2 SVN Revision 53 still can't parse this correctly.

comment:19 Changed 6 years ago by dgollub

Overseen someting! recieved-1.xml returns malformed because of sent-1.wbxml already sent malformed output... very likely that libsyncml is generating invalid SyncML XML request and wbxml is encoding malformed request for the device.

comment:20 Changed 6 years ago by jisakiel

Similar problems sporadically on my 6670 (as after using the given config I got it to sync... *once*).

Firmware version is v5.0509.0 28-02-05 RH-67; packages as in gentoo ~x86.

Something I noticed is if I let the connection as "ask me before" it always fails even if I authorize it.

If help is needed confirming or testing with it just tell me and I'll recompile everything with debug activated.

comment:21 Changed 6 years ago by add

about their apps in the first place. Both annotations and contributions will only clutter the interface by default as a design pattern rather than trying to put it all together. That way you can never create offline or print docs of high quality without again having the devs or current admins maintain the comments and annotations. Hopefully a small Wiki quality team will evolve (i am against ops or admins) to review and summarize the contributions. I hope this gives us more users as contributors than having the docs focused on the devs. Cheers, duns china tour Apparel shoes bags Kitchen Food and Wine Furniture) Flowers and Gifts Wall Art Computer Components I still prefer a wiki like approach since the php (or mysql) docs are very cluttered when you have to take their comments in account. On the other hand they are professionally maintained imho, since they are *much* better than KDE documentation.

comment:22 Changed 5 years ago by francisco1

  • Keywords 7610 added
  • Version changed from 0.21 to 0.22
  • Summary changed from Opensync reports an "no node at all" with nokia 3230 and nokia 6670 to Opensync reports an "no node at all" with nokia 3230, 6670 and 7610

I use nokia 7610. I have the same problem.

$ sudo syncml-obex-client -u 0 --identifier "PC Suite" --wbxml --version "1.1" --sync "text/x-vcalendar" Calendar --dumpinfo
connection with device succeeded
Received an Alert for the DS Server at Calendar: Type: 206, Last , Next 20081028T183645Z
Just received a new session with ID 21
Received the DevInf
Session 21 reported final. flushing
There was an error in the session 21: No node at allSend the output below to the libsyncml developers

========================================
Man: NOKIA
Mod: Catalina
FirmwareVersion: (null)
SoftwareVersion: 4.0437.4
HardwareVersion: (null)

ReceiveLimit: 0
MaxObjSize: 0
Connection used: OBEX Client
Identifier: PC Suite

Databases:
DB Locations: Calendar
DB Type: text/x-vcalendar
DB Slow: 0

Bluetooth: Unknown
Wbxml: Yes
SyncML Version: 1.1
SupportsNumberofChanges: Yes
SupportsLargeObjects: Yes

opensync-plugin-syncml:
  Installs: 0.22-2

How can I help?

comment:24 Changed 4 years ago by sim

decoration Changed 1 year ago by admin

bathtub Changed 1 year ago by admin

solar system Changed 1 year ago by admin

stair parts Changed 1 year ago by admin

solar supply Changed 1 year ago by admin

Note: See TracTickets for help on using tickets.