Ticket #395 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

IrMC plugin problem (svn version) - "Cannot connect via OBEX"

Reported by: judaz Owned by: cstender
Priority: normal Milestone:
Component: Plugin: irmc Version: 0.20
Severity: normal Keywords: timing obex irmc
Cc: gronslet@…

Description

This bug is based on the info from ticket 150 but is filed as a new bug (as requested). Please also read that ticket.

Using opensync svn version 1525 (irmc_bluetooth.c ver 1468) that has been built as a normal user according to the script given in ticket 388 (12/10/06 20:54:16), and trying to sync a Sony Ericsson T610 over bluetooth (obex) using the irmc-pluging fails:

$ ./msynctool --sync irmcfile --filter-objtype note
Synchronizing group "irmcfile"
Member 1 of type irmc-sync had an error while connecting: Cannot connect via OBEX.
Member 2 of type file-sync just connected
Member 2 of type file-sync just disconnected
All clients have disconnected
The sync failed: Unable to connect one of the members
Error while synchronizing: Unable to connect one of the member

No activity is reported by "hcidump -X -V". I am fully able to pair my cellphone using kbluetoothd (kdebluetooth daemon) and transfer files. I have given the correct channel (my IRMC channel reported by sdptool is 11).

I am using Fedora Core 6 (kernel 2.6.18-1.2849.fc6), and these are some relevant versions:

$ rpm -qa openobex\* bluez\*
bluez-gnome-0.6-1.fc6
openobex-apps-1.3-3.1
bluez-libs-devel-3.7-1
openobex-1.3-8.1
bluez-libs-3.7-1
bluez-utils-3.7-2
openobex-devel-1.3-8.1
bluez-hcidump-1.32-1

Change History

comment:1 Changed 7 years ago by judaz

  • Cc gronslet@… added
  • Keywords timing obex irmc added
  • Component changed from OpenSync to Plugin: irmc

comment:2 Changed 7 years ago by dgollub

  • Owner changed from abauer to cstender

Is the openobex package also from the BuildService?

Please try the openobex package from your distro if possible. The FC5 package from the BuildService seems to be broken. It is not build against bluez-libs (nor libusb)...

Let me know if a downgrade to openobex 1.3 from fc6 works for you... so Christopher can fix the package.

comment:3 Changed 7 years ago by judaz

Yep, seems that I've got openobex from the BuildService?:

# yum list openobex
...
openobex.i386                            1.3-8.1                installed
Available Packages
openobex.i386                            1.3-3.1                core

So, now I've downgraded:

# rpm -qa openobex\*
openobex-apps-1.3-3.1
openobex-1.3-8.1
openobex-devel-1.3-8.1
# rpm -e openobex-devel
# wget http://www.muug.mb.ca/pub/fedora/linux/core/6/i386/os/Fedora/RPMS/openobex-1.3-3.1.i386.rpm
# rpm -Uvh  --oldpackage openobex-1.3-3.1.i386.rpm

And HEY! We've got contact! "./msynctool --sync irmcfile --filter-objtype note" (in my svn installation dir) connects successfully, and "hcidump -X -V" reports alot of traffic.

Thanks alot - finally we can move on to actually debug opensync :)

comment:4 Changed 7 years ago by judaz

I just tried to rebuild from svn and ran into the problem

configure: WARNING: openobex-config not found. Perhaps openobex is not installed.
configure: error: You must have openobex 0.9.8 or openobex >= 1.0.0 installed.

when configuring the irmc-plugin. Of course one should have the openobex-devel package installed, so I installed it (from FC6 core repo, not Opensync FC5 repo), and the build went fine.

But the actual sync still doesn't seem to work..:

localhost:~/opensynctest/bin:$ ./msynctool --sync irmcfile --filter-objtype note
Synchronizing group "irmcfile"
The previous synchronization was unclean. Slow-syncing
Member 2 of type file-sync just connected
Member 1 of type irmc-sync just connected
All clients connected or error
Member 2 of type file-sync just sent all changes

First, the phone indacates that it is syncronizing, then, after a while, the phone disconnects (the bluetooth icon changes to "idle") but msynctool doesn't return. I believe my config is correct:

$ ./msynctool --showgroup irmcfile
Groupname: irmcfile
Member 1: irmc-sync
        Configuration : <config>
  <connectmedium>bluetooth</connectmedium>
  <btunit>00:00:00:00:00:00</btunit>
  <btchannel>11</btchannel>
</config>

Member 2: file-sync
        Configuration : <config><path>/home/MYUSERNAME/opensync-irmcfile/</path><recursive>FALSE</recursive></config>

(username and btaddr scrambled). The path for the file-sync does exist, but remains empty.

comment:5 Changed 7 years ago by judaz

Now that the "Cannot connect via OBEX" error is "fixed" I guess we can close this ticket (I am looking forward to see the FC6 opensync repo). I will do some more testing on the svn version and open a new ticket if I cannot make it work.

Thank you for all help this far :)

comment:6 Changed 7 years ago by dgollub

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for testing!

Note: See TracTickets for help on using tickets.