Ticket #577 (closed defect: fixed)

Opened 7 years ago

Last modified 6 years ago

libopensync-plugin-kdepim-0.33 does not build

Reported by: fundawang Owned by: ehabkost
Priority: normal Milestone:
Component: Plugin: kdepim Version: 0.33
Severity: normal Keywords:
Cc:

Description

There is missing files (datasource.h) in tarball, so it can not build. The same for libopensync-plugin-palm.

Change History

comment:1 Changed 7 years ago by dgollub

  • Status changed from new to closed
  • Resolution set to fixed

Fixed Makefile.am for kdepim-sync with r2597

Could you give me a hint about your libopensync-plugin-palm issue? palm-sync currently builds for me ... it's not yet fully ported, but at least the plugin builds.

Thanks for testing!

comment:2 Changed 6 years ago by fundawang

gcc -DHAVE_CONFIG_H -I. -I.. -I/usr/include/opensync-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -fexceptions -MT palm_sync.lo -MD -MP -MF .deps/palm_sync.Tpo -c palm_sync.c  -fPIC -DPIC -o .libs/palm_sync.o
mv -f .deps/palm_format.Tpo .deps/palm_format.Plo
/bin/sh ../libtool --tag=CC   --mode=link gcc -I/usr/include/opensync-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2    -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -fexceptions -avoid-version -export-dynamic -module  -o palm.la -rpath /usr/lib64/opensync/formats palm_format.lo -lpisock -lopensync -lglib-2.0 -lxml2    
palm_sync.c:24:23: error: palm_todo.h: No such file or directory
palm_sync.c:25:26: error: palm_contact.h: No such file or directory
palm_sync.c:26:24: error: palm_event.h: No such file or directory
palm_sync.c:27:23: error: palm_note.h: No such file or directory
make[2]: *** [palm_sync.lo] Error 1
make[2]: *** Waiting for unfinished jobs....

comment:3 Changed 6 years ago by dgollub

Ooops, i guess gcc included the parent directory of my root dist-check directory. I shouldn't generate distcheck tarballs an test them in my svn copies...

Thanks for the hint!

comment:4 Changed 6 years ago by dgollub

Ooops² - it got fixed with r2592 .. that's the reason i can't reproduce it :(

Note: See TracTickets for help on using tickets.