Ticket #815 (new task)

Opened 6 years ago

Last modified 6 years ago

OpenSync does not check plugin format capabilities

Reported by: tuju Owned by: dgollub
Priority: normal Milestone: OpenSync 0.40
Component: OpenSync: Format Conversion Version: 0.38
Severity: critical Keywords:
Cc:

Description (last modified by dgollub) (diff)

Leftover from commit r3563:

Add sanity check for "file" format. Currently "file" only supports this
format.
TODO: Move this sanity check into the framework.

Change History

comment:1 Changed 6 years ago by tuju

  • Summary changed from Move "sanity checks" from file-plugin into the framework to OpenSync does not check plugin format capabilities

Bellmich's #829 had more descriptive summary.

comment:2 Changed 6 years ago by tuju

  • Milestone changed from 0.38 to 0.39

This did not get fixed for 0.38 release, not a API blocker either. Moving ahead.

comment:3 Changed 6 years ago by tuju

  • Version changed from 0.36 to 0.38

comment:4 Changed 6 years ago by dgollub

  • Description modified (diff)
  • Severity changed from normal to critical

Bump severity to get fixed for 0.39

comment:5 Changed 6 years ago by dgollub

  • Component changed from OpenSync to OpenSync: Format Conversion

comment:6 Changed 6 years ago by dgollub

  • Milestone changed from OpenSync 0.39 to OpenSync 0.40

No API change required - moving to 0.40 milestone

Note: See TracTickets for help on using tickets.