Ticket #857 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

msynctool asserts when syncing notes with Nokia E50 (mapping_entry_uid)

Reported by: teprrr Owned by: dgollub
Priority: normal Milestone: OpenSync 0.39
Component: OpenSync: Engine Version: 0.37
Severity: normal Keywords: e50 syncml notes
Cc:

Description

I'm getting following assert when running msynctool for syncml->file when all "plugins" (notes, calendar, contacts) are enabled: /home/tpr/other/src/opensync/opensync/opensync/engine/opensync_mapping_entry_engine.c:98:E:osync_entry_engine_matches: Assertion "mapping_entry_uid" failed Aborted

When not all of those are enabled from the config file it won't assert, but instead never finish the operation. Without having notes enabled it works just fine.

See http://opensync.org/wiki/Nokia_E50#Configurationforsyncingdatawithcurrentdevelopmentversionasof20080910 for used versions and configuration files used.

Attached console output and OSYNC_TRACE files.

Attachments

console-output (8.6 KB) - added by teprrr 6 years ago.
Console output
Thread1107982672-17255.log (282.4 KB) - added by teprrr 6 years ago.
Thread1116375376-17255.log (38.5 KB) - added by teprrr 6 years ago.
Thread1158338896-17255.log (269.5 KB) - added by teprrr 6 years ago.
Thread1191909712-17255.log (8.0 KB) - added by teprrr 6 years ago.
Thread1200302416-17255.log (180.5 KB) - added by teprrr 6 years ago.
Thread140184856319872-17255.log (75.3 KB) - added by teprrr 6 years ago.

Change History

Changed 6 years ago by teprrr

Console output

Changed 6 years ago by teprrr

Changed 6 years ago by teprrr

Changed 6 years ago by teprrr

Changed 6 years ago by teprrr

Changed 6 years ago by teprrr

Changed 6 years ago by teprrr

comment:1 Changed 6 years ago by teprrr

Wanted to mention that this works just fine:

syncml-ds-tool -b 00:00:00:00:00:00 10 --identifier "PC Suite" --read-only --wbxml --sync text/plain Notes

comment:2 Changed 6 years ago by felixmoeller

  • Version changed from 0.38 to 0.37
  • Summary changed from msynctool asserts when syncing notes with Nokia E50 to msynctool asserts when syncing notes with Nokia E50 (mapping_entry_uid)

move back to current release ;)

comment:3 Changed 6 years ago by tuju

  • Milestone changed from 0.40 to 0.39
data sink of member 1 of type file-sync just sent all changes
/home/tuju/PKGS/BUILD/libopensync-0.37svn3709/opensync/engine/opensync_mapping_entry_engine.c:98:E:osync_entry_engine_matches: Assertion "mapping_entry_uid" failed
zsh: abort      msynctool --sync file-e71

Same happens here. I've kdepim Directory resource and opensync file-sync using the same directory:

[tuju@wasa]~/.pim/contacts% grep UID *
Rp1wO0HMaY:UID:Rp1wO0HMaY
zCAS8YnKM1:UID:zCAS8YnKM1
[tuju@wasa]~/.pim/contacts%

comment:4 Changed 6 years ago by tuju

  • Status changed from new to closed
  • Resolution set to invalid

This was caused by wrong configuration, here is the correct one:

<?xml version="1.0"?>
<config version="1.0">
  <Resources>
    <Resource>
      <Enabled>1</Enabled>
      <Formats>
        <Format>
          <Name>file</Name>
        </Format>
      </Formats>
      <ObjType>contact</ObjType>
      <Path>/var/tuju/pim/contacts</Path>
    </Resource>
  </Resources>
</config>

We could have some sane error message if possible or then fix the intermixed data syncs. Anyway, thanks to dgollub for helping out with this one.

comment:5 Changed 6 years ago by dgollub

  • Component changed from OpenSync to OpenSync: Engine
Note: See TracTickets for help on using tickets.