Ticket #858 (closed defect: invalid)

Opened 6 years ago

Last modified 5 years ago

[NEEDINFO] libsyncml doesn't transfer ADR field without an attribute (WORK, CELL, HOME, etc)

Reported by: tuju Owned by: tuju
Priority: normal Milestone:
Component: Plugin: syncml Version: 0.38
Severity: normal Keywords: libsyncml, syncml
Cc: niels@…

Description

Quite many people have got bitten by this.

syncml-ds-tool -b 00:00:00:00:00:00 10  --wbxml --dumpinfo  --identifier "PC Suite"  --sync text/x-vcard Contacts

results

BEGIN:VCARD
VERSION:2.1
REV:20071227T155408Z
ORG:ABC;
END:VCARD

kind of card, even the card would have TEL defined, but no Business or other attribute. Same can happen to ADR and EMAIL fields (so far known problematic fields).

Another problem is, that for example Kaddressbook, you cannot define EMAIL attributes at all. For ADR/street addresses you can untick the all radio buttons causing them to get lost in sync.

We also noticed in Berlin dev meeting that this also happens with PC Suite and e65, when run in vmware and on Linux host os + wireshark sniffers.

We need to get another similar native environment and repeat that test to make sure that it also happens with pure vendor products.

Also, it depends on - for example on different Nokia models - that can you define fields with/without these types. E9300 allows default types without attributes, E65 by default defines them, but can contain plain ones without attributes if they get synced to phone.

Note that this causes data loss.

This is in wrong ticket system but i don't have access rights in libsyncml.opensync.org.

Change History

comment:1 Changed 6 years ago by savago

I confirm this bug for Nokia E61 (S60 3ed.) and N95 (S60 3ed. FP1). I can test in other cellphone models if required.

comment:2 Changed 6 years ago by tuju

  • Status changed from new to closed
  • Resolution set to invalid

Okay, I downloaded pcsuite to vmware and upgraded those couple times, pcssuite 7.0.8.2 and phone firmware tool was able to upgrade my e65 phone:

old firmware: 1.0.633.18.01 new: 3.0.633.69.00

then i recovered backup from mem card, started sync to windows phonebook and after few attempts i was able to sync it, so that TEL, ADR and EMAIL fields were synced too.

Also, my firmware upgrade was horrible, it crashed in the middle and from year ago attempt I remember that phone had to be taken into service to be flashed again. This time the tool suggested recover which never succeeded, regardless of multiple attempts. Anyway, the tool shows that firmware is now latest and also the *#0000# shows it too. Seems to work, calls etc.

I close this bug now as this was purely caused by upstream issues.

comment:3 Changed 6 years ago by tuju

  • Status changed from closed to reopened
  • Resolution invalid deleted

Well, there is still something fishy with libsyncml.

Contact that didn't transfer mobile and email before, now does it transfers them, but not the ADR field.

That particular that I've been looking at, didn't have any attribute on it and on pcsuite+windows, it ends up to Business (WORK) page as it categorizes information by attribute, into different tabs. Other card that has only telephone in e65, looks like this as vcard:

BEGIN:VCARD
VERSION:2.1
REV:20071227T115748Z
ORG;ENCODING=QUOTED-PRINTABLE;CHARSET=UTF-8:Avis=20Estonia=20O=C3=BC;
TEL;VOICE:+3726671500
END:VCARD

so it travels with an attribute. And it seems that windoze/pcsuite shovels those too into business category. luckily those .wab files are binary, wouldn't have been that interested how windows stores those and is the VOICE still there.

Nope, this case is not closed yet.

comment:4 Changed 6 years ago by tuju

  • Summary changed from libsyncml doesn't transfer TEL, ADR and EMAIL without an attribute (WORK, CELL, HOME, etc) to libsyncml doesn't transfer ADR field without an attribute (WORK, CELL, HOME, etc)

removed TEL and EMAIL from summary as those were caused by old phone firmware.

comment:5 Changed 5 years ago by bricks

  • Keywords libsyncml, syncml added
  • Component changed from OpenSync to Plugin: syncml
  • Milestone 0.38 deleted

comment:6 Changed 5 years ago by tuju

  • Status changed from reopened to new
  • Severity changed from blocker to normal
  • Summary changed from libsyncml doesn't transfer ADR field without an attribute (WORK, CELL, HOME, etc) to [NEEDINFO] libsyncml doesn't transfer ADR field without an attribute (WORK, CELL, HOME, etc)
  • Priority changed from high to normal
  • Version changed from 0.37 to 0.38
  • Owner changed from dgollub to tuju

I need to re-test this with current. Close in 30 days if no response.

comment:7 Changed 5 years ago by niels

  • Cc niels@… added
  • Status changed from new to closed
  • Resolution set to invalid

Closing as no more information has been provided within 30 days.

If you are still experiencing the originally reported problem, please (re-) open this / a new ticket with the requested information.

Note: See TracTickets for help on using tickets.